Can I go running with just my iwatch4?


#1

Hi,

I like to go running with just my iwatch4 and I have GPS on it but when I got home. My iwatch Sweatcoin app said I didn’t record any steps outside. How is this so? I started the Sweatcoin App on my iwatch before I left my house? Anyone else have this problem?

Thanks,
Staci


#2

I don’t run with a smart watch, or one with the sweatcoin app, so I can’t say much on this issue. An Apple Watch Series 4, however, is a pretty quality smart watch so I highly doubt it’s issues with the GPS. Might be best to contact support


#3

Hey! I believe @Phatt.One may be able to help you out here, I think he uses apple watches and knows the tips n’ tricks :slight_smile:


#4

Gday
I use the Apple Watch S4 GPS only myself. I have to admit I personally haven’t had any major issues. However, there has been the odd occasion where the watch app has hung but not for a quite a long time now.
Do you by any chance record your workouts using the standard watch workout app or any other GPS activity apps? The reason I mention this is that with apps such as those you can view a map of your run and this would help confirm that the GPS on the watch is active and functional to start with. I would check the watch settings to ensure location sharing is enabled just to be sure. If all else fails, try removing the app from your watch and then re-enabling i if all else fails, try removing the SWC app from your watch, Restarting your watch, then reinstalling it back to the watch. Try a couple of short treks to test it and see if it corrects the issue.

Let me know how you get on and if you are still experiencing issues, I will try and take a deeper look myself to see if I’ve missed anything. If I fail completely then it might be worth raising it with sweatcoin support to see if they have suggestions. I know the actual app works so it may be just an installation or settings issue and removing/reinstalling should prompt and resolve the issues just make sure you agree to all the sharing options during in I know the actual app works so it may be just an installation or Settings issue and removing/reinstalling should prompt and resolve the issues just make sure you agree to all the sharing options during in-store install.


#5

Thanks for all the help guys! I appreciate it. I use the Strava app for running and cycling. Trying to get back into running more to get those coins (haha!) but Strava tracked my gps, time, distance, etc just fine so I’m not sure if both the apps (Strava and Sweatcoin) can run simultaneously. I don’t know if one app kicked off the other one. Do u know if anyone who has both apps before and hasn’t had an issue. I guess I’ll have to retry again running both the apps at the same time on my next run and see if the same thing happens.


#6

It might be running 2 gps apps at the same time thing. I run Strava and Sweatcoin at the same time. Thanks for the help


#7

Good looking out and sending my message to him! He did reply gave me a few tips. I appreciate it. Just started using Sweatcoin app and reading all about it.


#8

Just a bit of a follow-up. Have you managed to get any success with the SWC app on the watch? I have admit I don’t really run any other GPS apps on my watches. Recording GPS activity really does seem to batter the battery. I have to alternate two Apple watches most days and carry a travel charge case to charge one and wear the other. I was going to try Strava to keep the statistical info but they wanted money and at the moment all my spare cash goes on compression socks and new trainers :rofl:


#9

Nope nothing. It’s still not counting my steps. I walked my dog yesterday morning and we walked 4.35 miles outside and SweatCoin said I had 9,867 steps outside just from the walk. I check right after we finished our walk at the garage. I was like, Awesome that’s almost $10 SweatCoins! but than come to find out. I only got $5.05 in SweatCoins. What happening? I should had more SweatCoins. I did work around our pool to later in the day and I’m not sure those counted either. This totally bums me out. I was really pumped about this app. You only get half the money for 100% work. Please help me fix this problem. I really wanted to use this app. GPS is working good. My Strava account recorded my walk just fine and it didn’t record my steps from my run this morning either. I have no idea what the problem is. It recorded zero steps from my run but Strava recorded everything for me. Help plz!!!


#10

Unfortunately, I don’t personally work for Sweatcoin so I can’t offer any official assistance or official comment. Obviously, I have a very strong belief in the app and will try my best to help anyone I can to get it working and get the best they can from it. Sweatcoin does say that a conversion rate of around 65% is considered acceptable. Although this applies to the mobile app I do not know if it applies to the watch application and functionality, I have never personally experienced any major issues with the watch. With the mobile, the conversion rate has been very variable. I seem to remember at some point around 12 months ago I published a screenshot showing amazing conversion where I lost possibly 2% on my steps and that was it. Then a prime example of losses would be on the Saturday just gone, my actual steps showed as 865551 but only 70000 were actually verified as Sweatcoin steps. In contrast, the first time I did the 100k steps, I actually completed 102k steps just to bring the verified sweatcoin steps over 100k and to lose only 2k steps over that distance is just phenominal. In the past I have been miffed over losses and felt disheartened but when you consider that at the end of the day, these guys are giving you a free application to convert the steps from activity you are doing anyway into a currency you can spend, any conversion is a bonus really.

All that being said, I will install Strava and open a trial account and knock my phone off to test going “watch only” for my first 10k steps and try to record the activity on Strava and Sweatcoin together to see if the issue occurs. If i lose 10k steps on the day I’m not too bothered… I will just have to walk further to make up the lost steps afterwards.

I will of course share my findings with you. Sadly, I don’t have a pool. I’m sure if I did I would swim rather than walk around it :crazy_face: only messing. I can select a larger puddle, it’s raining cats and dogs and possibly rabbits too around here right now.

I would suggest contacting support if I can’t find a solution. If the results of my tests also show fault I will also pop a note in to support but please take into consideration that with the number of users worldwide, the number of devices that run the apps and that Sweatcoin will not have thousands of support staff… they are extremely busy and can’t be expected to have a lightning fast response time. So, please be patient.


#11

My apologies, Apparently I’ve already trialed Strava and it’s kicking up a fuss with my details. I’ll try and record an “Activity” workout at the same time.
A thought springs to mind… the Healthkit has options to select the order for prioritising data sources. I can’t see how it would effect the results because I don’t know if the Sweatcoin app on the watch is classed as “Apple Watch” or “Sweatcoin” in the HealthKit preferences.
I’m about to head out for the nighttime trek so will let you know later how I get on. :sunglasses::+1:t4:


#12

Wow!!! You don’t even work for them and you are going far and beyond to help me. Thanks a ton! I have no idea what ur results will be like but I hope you have better luck than me. I didn’t know if running both the apps would work or not at the same time if i just took my iwatch on my run. Let me know which app you started first before you took off on ur run. I start Sweatcoin and than Strava. I tried looking for that priority ranking and I couldn’t find that list to see which app is ranked 1st.

Maybe I’ll have to take my iPhone with me to run each app separate but I don’t really want to take my iPhone if I can help it on short runs. Maybe on longer runs when I have my pack with me. Maybe that’s something I’ll try tomorrow and see how it goes. Just as a trial and error.


#13

Hi
I just like to try and help other users whenever I can. :sunglasses::+1:t4:
Was this the screen you saw on your watch?
image
I managed to install Strava whilst I was out in the end. Like yourself I tried running both apps, starting them in different orders. Both ways round, I ended up with this screen and rebooted the phone to get Sweatcoin to re-pair with the phone.
I’m sorry to say that it looks like I have had the same issue as you had. Lost the steps in Sweatcoin app but recorded all the Strava data.
Having also done a little extra research on my way round this morning, I did find that this is a common problem experienced… Not just with Sweatcoin but with any two fitness apps fighting for the same data. Apparently, my guess was correct and it is down to the HealthKit priorities ensuring that activities are not duplicated. The process is called ‘deduping’. The only data recorded in the health app that is not subject to deduping are those items like caffine or water etc. that are not strictly related to movement.

The below is to an article regarding the management and prioritisation of HealthKit data.

Looks like you might have to take your phone to record Strava and Sweatcoin data after all.

Sorry the result didn’t resolve the problem.