Difficulty connecting Gfit with sweatcoin. Android


Have been trying to connect my sweatcoin app with Google fit, but after selecting my Gfit account the loading screen is as far as I get. I’ve tried multiple times, both over WiFi and 4g and have been stuck on the loading icon each time.
Anyone with a similar experience or am I doing something wrong?


I’ve been having this issue myself, I go to activate it pops up with account selection I select my account and it sits and loads doing nothing else I get no further than this.

It’s really annoying as this is a feature I have wanted and now it’s here I can’t use it. :disappointed:

If anyone could help would be greatly appreciated. :grin:


I’m having exactly the same problem. I tap “Enable Google Fit Access”, then tap the Google account I want to link to, then all I get is a white box with the spinning yellow/green/blue/red circle. However long I leave it it just stays the same with the spinning circle.

Can this be fixed, please?


try the answer at the link above worked for me :grin:


Thanks, that worked.


Glad i could help but all credit to @Rabatts for having the answer :smiley: