Huawei users -- we're in need of your help!


#1

To our Huawei users,

We need your help!

Despite our best efforts with the launch of our new algorithm (which now counts indoor steps!), we hear that some of you are still having issues with the conversion of your steps to sweatcoins.

Please see below some tips which have proven to have helped many of our Huawei users, and if you’Ve experienced any issues, we’d encourage you to give these a try!

Before this though, always make sure you’ve installed the latest version of Sweatcoin from the PlayStore (we’re releasing new versions all the time!) :slight_smile:

  1. In your device, go to “Settings” > “Apps” > find “Sweatcoin” > ensure Power saving mode toggle is OFF

  2. In your device, go to "Settings > “Apps” > Three dots at the top > “Special Access” > “Battery Optimisation” > “Not allowed” switch to “All apps” > Find “Sweatcoin” > Click on Sweatcoin > Choose “Don’t allow” (this can be done by request from the app like on Samsung)

  3. Settings > Battery > App launch > Find Sweatcoin > Disable switch > Keep all switches in opened popup as enabled (Auto-launch, Secondary launch, Run in background) Click “OK” (this cannot be adjusted from the app)

We also heard back from a user recently who realised that another fitness app he had downloaded was affecting his conversion. Once he uninstalled that app, everything worked perfectly again after just a few hours! That said, please also make sure also that you don’t have any other fitness apps downloaded on your device which could be interfering.

Please let us know if any of these steps worked for you (there are sweatcoins in store for anyone who can help us, and other users, out on this one!).

Let’s get all our Huawei users happily Sweatcoining again!

Team Sweatcoin


pinned #2

#3

Hey, thank you for this!

I got sweatcoin working by using step 2.
(Hauwei Honour 7A)


#4

This is amazing news! Thanks so much for letting us know.


#5

Hi,

My steps are counted but the conversion is blocked.
The “Analyse now” doesn’t work anymore.

It works for a few minutes when I re-install the app but the next day, it stops working again.

PlongeurFou


#6

I have exactly the same problem on my p20 pro. Very frustrating!


#7


The number of steps i’m loosing today !


#8

@plongeurfou @BT_86 Have you tried out the steps above? Please let us know if any of them work :slight_smile:


#9

Hi,

I have try the steps many Times. Thé steps are counted but they are not converted to sweatcoins.

Plongeurfou


#10

Yes I have tried all the steps and none of them work. I can only get it to work if I reinstall but it only works for about a day.