No location services?


Hey there! I’m frustrated because the app on my iPhone (iPhone X) isn’t counting the steps from my watch (series 3 Apple Watch) each day. I tried to check several times to see if I could connect the watch app to the iPhone And it continues to ask me to enable location services on the iPhone.

Here’s where it gets messy. There is no location services option with the iPhone settings for Sweatcoin. Rigged by the app to decrease number of steps you can get approved? I surely hope not.

I’ve tried uninstalling the app on both iPhone and the watch… nothing. I’ve tried to find location services on iPhone and the watch side, nothing.

Please help?


Hey! Location services shouldn’t be needed now from our new algorithm. Please make sure you’re on the latest update on your phone and watch.
I don’t have an apple watch myself, so i’m not too good with fixes for it. Perhaps our resident watch pro @Phatt.One has some tips?


To be fair on one of the last updates I got messages on the watch to activate healthkit access, motion services and location services. As far as I am aware, the watch app still runs using the GPS algorithm, even when paired with an iPhone 7 or newer running the latest version of the Sweatcoin app. (Indoor steps still get converted but only from the iphone sensor source data).

However, I do have a location service listing for the Sweatcoin app.

Might be worth a quick read through the reply to a post from another user that experienced the same issue…


i have the same issue. i have an iphone pro and an apple watch series 5. when i attempt to search for sweatcoin to ensure location services are set to always, sweatcoin isn’t listed. yes the app is installed on my phone and watch with the most up to date versions in the app store and the OS software on the phone and watch have latest versions available. thank you in advance.


I’m currently also having the same issue. I have an Iphone 11 and Apple watch series 3. The app on my watch keeps telling me to activate location services but the app is not listed in my phone, or it keeps saying to activate motion (that is already activated for the app).

Without sorting out this issue, the app won’t record any steps i do, if im not actually holding my phone on me, wich is hard to do if I want to excerside.
Please give follow up, because if not I will have to delete the app, not really worth all the troubles.


I have tried al the things above, but I still have the same problem as well, it is really starting to annoy me, I have been trying to fix this for over a week now, did not find anything that could help me so far. I find it particularly weird that Sweatcoin does appear in the location services for my Apple Watch 5, but not for my iPhone 8.



I too was having the same issues. when i initially would open the app on my watch it would ask me to turn on location services but i couldn’t find where to do that.

I fixed this for my watch though by uninstalling the app from my watch and re-installing it as well as closing the app on my phone. when i opened the app on my watch again, instead of asking me to turn on my location, it told me to open the app on my phone, which then on the phone it allowed me to click “allow” for the app to use my location. after that it was working on my watch perfectly fine.

i hope this helps and works for everyone else.