Please enable location services Apple watch


When I try to open the app on my Apple Watch it says: “please enable location services on your iPhone”, however when I go to the settings on my iPhone, the app doesn’t appear in the location services tab, and on the Apple Watch it does, but it says that it will ask for permission of enabling the location services when opening the app? So now it doesn’t work on my Apple Watch.



I’m having this issue too…so looking forward to a resolution!


Any news? I don’t carry my phone as much as my watch…I’m missing 8k steps today!!


@ianfoxall we are working on it, will start testing early next week. It is a bit complicated.


Great! Thanks for letting me know.
If you need any Beta testing (or any other testing for that matter!) I’m happy to assist :+1:


I am experiencing this exact issue


After I updated the Sweatcoin app yesterday, theN today I open app on Apple Watch shows “please enable motion services on your iPhone”, I checked my iPhone setting, yes I did turn on, I tried re-install the app on Apple Watch and restart iPhone and Watch, none of them is working.

Please help.
Thank you


Now the app is working on my Apple Watch! Thank you


Today, there is new update of Sweatcoin app, I gave it a try, but no luck, I did try reset my Apple Watch as new watch and also try to upgrade Apple Watch OS, and try restart and reinstall app in watch and iPhone sere all times. No luck, none of methods works, open Sweatcoin app on Apple Watch always shows “Please enable Motion Services on your iPhone”. I did check setting on my iPhone and open Sweatcoin app on iPhone, and setting is turned on, and Sweatcoin app on iPhone is working.


Hi @deandeanr

Did you do anything? Could you share your case how your Apple Watch is working?

Thank you,



Finally, I get it works by updating iPhone iOS and Apple Watch OS to the latest version.



Thank you for letting us know. Glad it worked finally!

Do you remember which version you had when it didn’t work? It will help us to pinpoint this issue in future for other users.


Hi @khmelev,
Mine is still not working.
I have the latest iOS for phone and watch, and the app is up to date.
Has the issue been resolved as far as you know?


@ianfoxall could you please delete app on your phone and watch and reinstall it? If you can then record a video with how it works for you since first open it will be much appreciated. Just use any file sharing service to upload this video and share link here


Me too getting same issue.