Steps counted on Apple Watch not recognised on IPhone


#5

Thanks for the detailed response. Much appreciated. Yeah, seems like you addressed what I was asking. So if I go out with just the watch, steps won’t be counted unless I go into the app on the watch and click ‘begin earning’ and this can’t be done while logging my run with the workout app? Ahh that’s disappointing. Hope that changes soon.


#6

Yeah, its a bit frustrating it doesn’t just count in the background like the mobile app. I don’t know for sure but if the watch app is adapted to function using the v2 algorithm using motion data rather than relying on the location datasets, it may end up just working without the stop/start requirement. I can’t say for sure but it would make sense. Unfortunately, dual logging restrictions on WatchOS devices are a product of Apple’s handy work rather than an omission by Sweatcoin.


#7

Fingers crossed. Guess I’m gonna have to have my phone bobbing around in my pocket when I go running in the meantime.


#8

@antinatalist there are other options to carry your phone that don’t involve your shorts being pulled down.

Fanny-packs / bumbags work.

A flip-belt is a comfortable option.

Arm bands can be ok depending on the size of your mobile.

There are chest harnesses available.

My jacket has an arm pocket with phone strap.

My -5° to +5° Kalenji Trail Shirt has a compact zip pocket for mobiles etc. that falls in the small of my back.

Most of my running shorts have a zip pocket for mobiles at the back.

I have to admit that when I first discovered the ‘ass-pocket’ in the running shorts it confused the hell out of me. I’m not usually as thick as a brick but it took me a while to figure it out.

The only thing I would make note of is with belt style carrying options, be careful not to over-tighten… I managed to compress my femoral lateral nerve and as a result I have a patch of skin on the outside of my right thigh that has been without any sensation for a fair number of months now!


#9

Yes,
So I’ve heard. Until Sweatcoin came into my life this past week, I’ve always been happy to leave my phone at home when I go running/to the gym. Guess I’m gonna have to figure out the least inconvenient/irritating of the above options.


#10

The app on my Apple Watch (version 4) no longer works. It just simply doesn’t even launch anymore on my watch. Completely unusable.


#11

Damn, really wish they’d sort out the watch compatibility and have it run in the background regardless of whether or not other apps are running and your phone is with you.


#12

Hey @steviek sorry to hear you are having this problem. Have you tried using the watch app to uninstall and reinstall the WatchOS making sure you have the latest app version on your mobile (v38.1 was issued last week). I only mention it as a suggestion because a few months ago I had the same problem with my AW3 and this sorted it.
At the moment I have it functional on both the AW3 and AW4 (both GPS).


To be honest, I don’t think there has actually been any significant updates to the watch app in a while. Certainly, the new algorithm isn’t supported yet. I don’t work for Sweatcoin so couldn’t say for sure but as far as I know there are plans on the map to do some reworking on the AW app and possibly expand support to other wearables.

I hope you can manage to get the watch app up and working again soon.


#13

I need help everytime I go on sweatcoin on my Apple watch it says this I looked on location services but I can’t sweatcoin on there image


#14

Hey @EllisWalksALot
Sorry to read you are having issues. I don’t work for Sweatcoin but I have been using the Sweatcoin app for iOS paired with both AW3 and AW4 (obviously not at the same time) so will try and offer what help I can.

A few bits to check and please don’t think that I am being condescending in any way. I know that to some these things are obvious, where others may not be quite so familiar.

  • Which iPhone model is your Apple Watch paired with?

  • Which Apple Watch device is paired with your mobile device?

NB- Remember the Sweatcoin app must be installed on both the Watch and iPhone Devices.

  • Are iOS and WatchOS versions updated to the latest Standard public release?

  • Are the Sweatcoin applications on both your Apple Watch and the paired iPhone updated to the latest Appstore versions?

If the answer to any of these questions is No then ensure all version updates are completed and brought to the latest/current versions.

In order to check your location services are set, this is about the easiest way I can think of:

  1. Open Spotlight and search “Location”
  2. Tap “Location privacy
  3. Scroll down to “Sweatcoin” and Tap to select.
  4. Make sure the option “Always” is checked.

image

If you still experience problems after following the steps above, let me know and I’ll see what else Ai can think of that might help to resolve your current issue. :sunglasses::+1:t4:


No location services?
Apple Watch Help
#15

I Have an Apple Watch Series 3 paired to an IPhone XR they are fully up to date and sweatcoin is up to date and installed on both I can’t see sweatcoin on the list on location services


#16

I use an iPhone 7 plus with the AW 3 and 4 so all things equal, the configuration should be identical. The screenshots I took this morning when I read your post so technically, the Location setting pages should be the same. Did you manage to find the Location settings as illustrated? … if so, did you manage to get it sorted?

One suggestion might be to

  1. open the Watch app on your mobile.
  2. Scroll down to the Sweatcoin watch app and Tap to open the settings.
  3. Flip the switch to remove the watch app.
  4. Once, removed… flip the switch to show the app on the watch again.
  5. Restart the watch by holding the crown and side button until the display goes blank and the white Apple logo reappears and let go until the watch reboots fully.
  6. Open the Sweatcoin app on the watch first. This should display the starting message requesting that you open the Sweatcoin app on your paired mobile device.
  7. Make sure the Sweatcoin app is completely closed on your iphone.
  8. With the watch app running and in the active view, reopen the iphone app and allow it to fully load to the counter screen.

In most cases I have found this cears any location/motion request messages and any existing verified steps present on you iPhone should then update to show in the watch app.

Again these suggestions are based upon my own personal experiences with the Sweatcoin app for iOS and WatchOS


#17

Hi there

I have been using sweatcoin for about 3 years now and have not any issues with it on my phone at all. I recently purchased an Iwatch Series 5 and started going running without my phone and collecting coins via the watch. When I would get back home after a few minutes the coins would be successfully transferred to the app on my phone. Recently (past week or so) I finish the run, press stop on the sweatcoin app and it displays the coins earned and details of my run, but all I keep getting is “the server will notify you the amount of coins earned” message. I cant “force send” any more and if I press “done” on the watch then it disregards the work out. Any thoughts ?


#18

Hey @Andrew213284

I could be totally wrong but I don’t think there have been any changes made to the watch app for some time now.

Have you by chance started using the watch to record data for any other running apps at the same time? (Strava, Map my Run, Apple Workouts etc.)

Some users have highlighted that the data seems to get ignored when trying to use a second app that saves GPS data. From what I have dug out about this, for some messed up reason Apple has apparently coded the watch software to only allow access for one GPS data app at once on the Apple Watch.

This is only what I’ve found from my own research done when people have experienced issues. I’m no programmer and I don’t work for Sweatcoin, I can only offer my opinions and suggestions based on my own research and experiences in using Sweatcoin for iOS and Android.

I know I write this a lot in the forums but a few have taken the assumption I work for Sweatcoin and so I don’t want anyone taking any opinions, thoughts or suggestions as gospel :sunglasses::+1:t4:


#19

Hi there

Thanks for the speedy reply. I make sure that I don’t use any other running apps at same time as I am aware that this causes confliction with the sweatcoin app

It seems strange that it has only happened in the last couple of weeks or so - I have tried restarting my watch but the same thing happened yesterday. My only other thought may be that I belive there is a new Iwatch IOS update available so maybe I need to do that ?

Andy


#20

It certainly can’t hurt to run the update. I have to admit, I’ve not really had that many problems with the AW app. Any time I have had problems, the quick remove and reinstall of the watch app has always set it right again. That has always been on the Apple Watch three and four, not tried with 5 but the OS is the same so can’t see it making any odds between device versions.


#21

I have the same issue!


#22

Same problem here. Tanks to Phatt.One for your valuable input. I did follow your suggested steps. Something happened: The next time the Watch app instead asked me to “Please enable MOTION Services on your iPhone”…

Close but no cigar! :rofl:


#23

I have noticed a few people mention this issue of enabling motion services. Randomly, the past week my AW3 started showing me the same BS message. Although, To add insult to injury. It did start showing this message towards the end of an exercise session. Consequently I lost all the counted steps on the watch. Unfortunately, when I go for a trek REALLY go for a trek. Strange enough, (Touch wood). It hasn’t happened on my AW4. With the AW3 I uninstalled the Watch app and then set it to install again, restarted the phone and watch, checked the two were communicating and it has been fine ever since. Although, in all fairness, I think it is probably more down to good luck Rather than good judgement that I got it sorted :rofl:.


#24

Actually, I now realize, Sweatcoin doesn’t show at all under location services on my phone…
Did a re-install, allowing the app to enable location services - no show.

Under “Motion & Fitness” it shows, and is selected. The same is true under “Health”, it shows with all alternatives selceted. I have toggled the switches on and off. No difference. Also disabled everything but “steps”.

Even more confusing as Sweatcoins shows in location services on the AW, but I can’t change to “allways” on the Watch itself…

Worth mentioning: My friend had the same problem with the AW-app requesting location/motion services. He found Sweatcoin under location services, selected “Always”, after that - it’s been working like a charm. For me not so much.