Steps not converting to sweatcoins? Please read!


#214

Note: all edits are to update throughout the day.

Ok, today’s situation. @khmelev Please note that I’ve walked almost the whole time, outdoors. I was also holding with me my mom’s phone, which worked fine and is now showing 9,54 SWCs with 10,809 steps. (No picture.)
I haven’t done the boost yet, because in the past using the boost seemed to give me trouble.
Yesterday everything seemed to be working, but the boost came down to 0,00 on my phone.


I won’t reinstall, let me know what else you need.
Francis66618 , iPhoneSE

EDITING TO ADD that now, about 1 hour later (and I spent most of it sitting at home, with the phone on charge) more steps were converted, but not to the same amount as it should have.

More EDITING TO ADD that after the above pictures I went back outside and started walking again. Got a few more coins after walking some more.

And then I tried the boost:

And now I am in this situation:

By comparison, my mom’s phone whicj was in my other pocket gives me a boost of 2,41 with 2540 steps, and I’ve reached the max of 15 SWCs with a total of 16680 steps today (15789 are “good” for SWCs).
(Pictures are too large to attach).
It’s a Xiaomi Redmi Note 5, I think. Or 7. It doesn’t count indoor steps. User terry746377 .

So now do I keep walking all evening hoping to reach the maximum I’m “paying” for of 15 SWCs or do I stop, go have dinner, and hope that at some point it converts all the rest of the steps! Did it register all the steps? Or not, seeing as the boost gave me 0? Or do I have to find out at 11 pm whether O still need to go out to walk to get to my maximum of 15 SWC (which I can only do whilst I’m off work, of course. I won’t have this luxury once I’m back at work.)

EDITED FOR NEW UPDATE: stopped walking, took this picture and went inside, put my phone on charge, and this was the situation:


At 11:30 pm nothing else had been converted, same situati As above, sp went back to walk to see if I can get the 2 final SWC of the day. Will updated when I am done.

Final EDIT: done, hit 15 SWC, in about 15 mins, and considering I probably had some steps left to convert, that’s about how long it should have taken me.


There’s 8.6 SWCs there from the daily bonuses.
So sometimes it worked perfectly, but you can see that something went wrong earlier in the day.
That’s it, sorry for the loooong post, but I hope it’s thorough!


#215

I’ve taken a look at your data, and given that you’re on GPS algo this is pretty much typical conversion rate we see for other user as well: 60-70%. 16,025 steps has been approved for 24th and you’ve got converted 15,789 steps which gives you 15 SWC exactly due to your membership level.

I will take a look at your logs a bit later to see if I can find any faults, but for now it looks like everything works as expected.

EDIT: In regard Boost, it went wrong, I will ask our dev team to take a look once they back from holidays.


#216

Thanks, do please take a look at all my pictures because there’s something very not right: I finished at 23863 steps, so how did it only approve 16025? I kept walking round and round in the same area, at more or less the same speed, with both my phone and my mom’s. What happened to the other 7000 steps between 16000 and 23863? I walked very little inside my house, and most of the time without my phone on me. It looks like the problem started/was earlier on, around 3 or 4 pm.

I apologise for the long post!
So please, enjoy your Christmas first! :blush: There’s no hurry.
Merry Christmas to you and everyone at SWC!


#217

@khmelev It was 19th December. Screenshots show steps recorded and steps converted
image image


#218

Saidly, even now that there have been at least 5 updates since then the app only works properly at walking speed loosing at least 40% of steps at running speed and boost.

Used every trick and have a brand new iPhone so the problem has to be sweatcoin algorithm.

That really sucks since users are writing about this problem for months now…


#219

Please, open Health app -> Steps -> scroll down and find “Data Sources & Access” -> scroll down to section called “Data Sources” and find your iPhone in the list, click on it -> Take screenshot where 19th will be visible and send it here.


#220

Sadly I can see that app crashed within several seconds of you doing boost after you closed the app. I can also see “Out of Memory” errors which might mean that there are other apps which takes up free memory and system decided to kill ours (but it shouldn’t because of active GPS).

May I ask you to do following test. Reboot your device before you do your next boost (to ensure that there will be enough free memory), and if it won’t work well, please report it here once again so I can take a look again and see if it similar issue or not.

Thats might happen on old low end devices running new OS. We do work to optimise our software to use as little as possible resources, but GPS algo has less focus for us because of new Accelerometer algorithm which can only run on Apple A10 chip or later.

Thank you.


#221

Ok, I understood the problem with the boost, and I’ll make sure I’ll reboot my phone next time. That’s quite useful to know because it’s not the first time it happened. Thanks for your help.

But what about the 7000 missing steps on the 24th, which has nothing to do with the boost? Can you figure that out?

No problem if you can’t - everything worked perfectly both on the 25th, 26th and 27th.

It is not the app that I’m “complaining” about, because I do believe the problem is my phone and not the app. What I’m unhappy with is that I can no longer see when I do have a problem because of the lack of “steps awaiting conversion” we had before hand, so now I have to guess if I’m having issues, or only find out after I’ve walked a LOT more then necessary.


#222

@khmelev


#223

Same thing has happened again. 28th Dec Nearly 40k steps but only 2k were converted. It’s like the more I walk the less sweat coins I get. I can see that some were carried over to the next day, but since I hit the maximum limit that day I still lost a load. As others have said we need the ability back to force conversion

image


#224

Hey @khmelev, any update on what’s going on here?


#225

I’ve done 50k in steps these past 2 days and got 3 sw coins. I don’t bother complaining anymore, because all you’re asked to do is check your settings, and delete the app and upload again. Nothing ever comes from complaining. I wil just wait for it to start up again properly. I once had a whole month of issues, then it stared working again. Hardly the App to talk up about, when it’s so bad at customer services, and the apps always glitching


#226

Hey there, I set up the 2021 resolution but steps weren’t counted correctly in this section as well as sometimes I’m struggling with overall step conversion (I applied all suggestion from this article)

What can you suggest me ? Thank you


#227

Same here. I’m doing on average 17 to 20 k a day and only getting 1 sweatcoin. The 20 min boost is only giving me about 0.1 to 0 4 coins too
What’s going on?. Super glad I’m not paying this app anymore. I’m so close to leaving


#228

Yo. Your back then buddy.


#229

After 11 days of really bad conversions, and my 4th uninstall, the conversion is better, but not right still. The Creators/customer service robots, just say the usual. Check your settings, and uninstall… I could do there job better. Still the App is so terrible to it’s customers, paying or not…


#230

Oh no the very day after it starts to get better, it gets fecking terrible once more. 19500 steps, and 1swc is all I get, plus the bonus is useless in its conversions too.


#231

The app dont convert steps to sweatcoins. I already take 1000 steps but only 0,9 sweatcoins. My nick is Willovec, please help me.


#232

Happens all the time. Sometimes depends on what phone you have, and how compatible it works with the app. Just keep uninstalling. Seems to be the only thing that(eventually) works.
I’ve been here for 14 months, and I calculate I’ve lost, due to the app playing up nearly 1000 swc…


#233

Nicky969409
I have had the app for about two weeks now, I average between 1,000 and 10,000 steps a day but have only generated 2 sweatcoins as it only takes about 20 steps a day to convert. I have uninstalled and reinstalled the app but still not made a difference can anyone help please :persevere: